<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US"
xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<title>Great American Gun Show this weekend in LaBelle - Okeechobee News | Okeechobee News</title>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<!-- <link rel="stylesheet" type="text/css" media="all" href="https://okeechobeenews.net/wp-content/themes/newswire/style.css" /> -->
<link rel="alternate" type="application/rss+xml" title="Okeechobee News RSS Feed" href="https://okeechobeenews.net/feed/" />
<link rel="alternate" type="application/atom+xml" title="Okeechobee News Atom Feed" href="https://okeechobeenews.net/feed/atom/" />
<link rel="pingback" href="https://okeechobeenews.net/xmlrpc.php" />
<!-- <link rel="stylesheet" type="text/css" href="https://okeechobeenews.net/wp-content/themes/newswire/colors/default.css" /> -->
<!-- <link rel="stylesheet" type="text/css" href="https://okeechobeenews.net/wp-content/themes/newswire/css/media-queries.css" /> -->
<!-- <link rel="stylesheet" type="text/css" href="https://okeechobeenews.net/wp-content/themes/newswire/custom.css" /> -->
<link rel="stylesheet" type="text/css" href="//okeechobeenews.net/wp-content/cache/wpfc-minified/f7703e0ee9858941cffeff8081983eba/1516654642index.css" media="all"/>
<!--[if lt IE 9]>
<script src="https://css3-mediaqueries-js.googlecode.com/svn/trunk/css3-mediaqueries.js"></script>
<![endif]-->
<!-- MapPress Easy Google Maps Version:2.47.5 (http://www.wphostreviews.com/mappress) -->
<script type='text/javascript'>mapp = window.mapp || {}; mapp.data = [];</script>
<!-- This site is optimized with the Yoast SEO plugin v6.2 - https://yoa.st/1yg?utm_content=6.2 -->
<link rel="canonical" href="https://okeechobeenews.net/community-news/great-american-gun-show-weekend-labelle/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Great American Gun Show this weekend in LaBelle - Okeechobee News" />
<meta property="og:description" content="LABELLE &#8212; The Great American Gun Show will be at the LaBelle Civic Center, 481 Hickpochee Ave., LaBelle (right behind city hall) Feb. 3 and 4. Saturday hours will be 9 a.m. to 5 p.m. Sunday hours will be 10 a.m. to 4 p.m. Children age 12 and under will be admitted free with adult &hellip;" />
<meta property="og:url" content="https://okeechobeenews.net/community-news/great-american-gun-show-weekend-labelle/" />
<meta property="og:site_name" content="Okeechobee News" />
<meta property="article:publisher" content="http://www.facebook.com/okeechobeenews" />
<meta property="article:tag" content="business" />
<meta property="article:section" content="Community News" />
<meta property="article:published_time" content="2018-01-31T13:29:45-05:00" />
<meta property="fb:app_id" content="103764836632626" />
<meta property="og:image" content="https://okeechobeenews.net/wp-content/uploads/2018/01/Great-American-Gun-ShowLaBelle-1.jpg" />
<meta property="og:image:secure_url" content="https://okeechobeenews.net/wp-content/uploads/2018/01/Great-American-Gun-ShowLaBelle-1.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="600" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="LABELLE &#8212; The Great American Gun Show will be at the LaBelle Civic Center, 481 Hickpochee Ave., LaBelle (right behind city hall) Feb. 3 and 4. Saturday hours will be 9 a.m. to 5 p.m. Sunday hours will be 10 a.m. to 4 p.m. Children age 12 and under will be admitted free with adult [&hellip;]" />
<meta name="twitter:title" content="Great American Gun Show this weekend in LaBelle - Okeechobee News" />
<meta name="twitter:site" content="@OkeechobeeNews" />
<meta name="twitter:image" content="https://okeechobeenews.net/wp-content/uploads/2018/01/Great-American-Gun-ShowLaBelle-1.jpg" />
<meta name="twitter:creator" content="@OkeechobeeNews" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/okeechobeenews.net\/","name":"Okeechobee News","potentialAction":{"@type":"SearchAction","target":"https:\/\/okeechobeenews.net\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/okeechobeenews.net\/community-news\/great-american-gun-show-weekend-labelle\/","sameAs":["http:\/\/www.facebook.com\/okeechobeenews","https:\/\/twitter.com\/OkeechobeeNews"],"@id":"#organization","name":"Okeechobee News","logo":"http:\/\/okeechobeenews.net\/wp-content\/uploads\/2015\/09\/arizona-favicon.jpg"}</script>
<!-- / Yoast SEO plugin. -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Okeechobee News &raquo; Feed" href="https://okeechobeenews.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Okeechobee News &raquo; Comments Feed" href="https://okeechobeenews.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Okeechobee News &raquo; Great American Gun Show this weekend in LaBelle Comments Feed" href="https://okeechobeenews.net/community-news/great-american-gun-show-weekend-labelle/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/okeechobeenews.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.2"}};
!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<meta content="/home/okeechobeenews/public_html/wp-content/themes/newswire/style.css v." name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<!-- <link rel='stylesheet' id='shortcodes-css'  href='https://okeechobeenews.net/wp-content/themes/newswire/functions/shortcodes/shortcodes.css?ver=4.9.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='gglcptch-css'  href='https://okeechobeenews.net/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.33' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mappress-css'  href='https://okeechobeenews.net/wp-content/plugins/mappress-google-maps-for-wordpress/css/mappress.css?ver=2.47.5' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='junkie-shortcodes-css'  href='https://okeechobeenews.net/wp-content/plugins/theme-junkie-shortcodes/assets/css/junkie-shortcodes.css?ver=4.9.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='tablepress-default-css'  href='https://okeechobeenews.net/wp-content/plugins/tablepress/css/default.min.css?ver=1.9' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='__EPYT__style-css'  href='https://okeechobeenews.net/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=4.9.2' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//okeechobeenews.net/wp-content/cache/wpfc-minified/52168ff0ca2dbbaaa2d9b6ed630554c4/1516654642index.css" media="all"/>
<style id='__EPYT__style-inline-css' type='text/css'>
.epyt-gallery-thumb {
width: 33.333%;
}
</style>
<!-- <link rel='stylesheet' id='jetpack_css-css'  href='https://okeechobeenews.net/wp-content/plugins/jetpack/css/jetpack.css?ver=5.7.1' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//okeechobeenews.net/wp-content/cache/wpfc-minified/78dc299d75fd51497d3e4d0aa9584521/1516654642index.css" media="all"/>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js?ver=1.10.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script src='//okeechobeenews.net/wp-content/cache/wpfc-minified/dd3cab5b892413d9fb765247bc08c289/1516654651index.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://okeechobeenews.net/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script> -->
<!-- <script type='text/javascript' src='https://okeechobeenews.net/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=4.9.2'></script> -->
<!-- <script type='text/javascript' src='https://okeechobeenews.net/wp-content/themes/newswire/functions/shortcodes/shortcodes.js?ver=1.0.0'></script> -->
<!-- <script type='text/javascript' src='https://okeechobeenews.net/wp-content/themes/newswire/includes/js/jquery-ui-1.8.5.custom.min.js?ver=1.8.5'></script> -->
<!-- <script type='text/javascript' src='https://okeechobeenews.net/wp-content/themes/newswire/includes/js/superfish.js?ver=1.4.2'></script> -->
<!-- <script type='text/javascript' src='https://okeechobeenews.net/wp-content/themes/newswire/includes/js/custom.js?ver=1.4.2'></script> -->
<!-- <script type='text/javascript' src='https://okeechobeenews.net/wp-content/themes/newswire/includes/js/scrolltop.js?ver=1.0'></script> -->
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=1.0'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='https://okeechobeenews.net/wp-json/' />
<meta name="generator" content="WordPress 4.9.2" />
<link rel='shortlink' href='https://wp.me/p7Bxc0-2F3' />
<link rel="alternate" type="application/json+oembed" href="https://okeechobeenews.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fokeechobeenews.net%2Fcommunity-news%2Fgreat-american-gun-show-weekend-labelle%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://okeechobeenews.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fokeechobeenews.net%2Fcommunity-news%2Fgreat-american-gun-show-weekend-labelle%2F&#038;format=xml" />
<meta property="fb:app_id" content="103764836632626"/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel="shortcut icon" href="https://okeechobeenews.net/wp-content/uploads/2015/09/arizona-favicon.jpg" /><!-- Custom Styling -->
<style type="text/css">
.entry-content p {
font-size: 16px;
line-height: 25px;
}
.entry-content ul {
font-size: 16px;
line-height: 25px;
}
.entry-content ul li {
padding: 2px 20px 15px 15px;
}
.entry-tags::before {
border-top: 1px solid #ddd;
content: "";
display: block;
margin-bottom: 1em;
min-width: 30px;
width: 100%;
}
body {
font: 12px/19px Georgia, Arial, "Lucida Grande", sans-serif;
}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="amphtml" href="https://okeechobeenews.net/community-news/great-american-gun-show-weekend-labelle/amp/"><!-- custom CSS -->
<link rel="stylesheet" type="text/css" href="https://delawarestatenews.net/inicustom.css"/>
<!-- Doubleclick -->
<script type='text/javascript'>
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/83779297/fl-leaderboard-01', [728, 90], 'div-gpt-ad-1372687360134-0').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mediumrectangle-01', [300, 250], 'div-gpt-ad-1372687360134-1').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mediumrectangle-02', [300, 250], 'div-gpt-ad-1372687360134-2').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mediumrectangle-03', [300, 250], 'div-gpt-ad-1372687360134-3').addService(googletag.pubads());
googletag.defineOutOfPageSlot('/83779297/fl-mobile-adhesion-01', 'div-gpt-ad-1454707238781-4').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('community', ['Okeechobee']);
googletag.pubads().enableSyncRendering();
googletag.enableServices();
});
</script>
<!-- /83779297/fl-mobile-adhesion-01 -->
<div id='div-gpt-ad-1454707238781-4'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1454707238781-4'); });
</script>
</div>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-64247352-1', 'auto');
ga('send', 'pageview');
</script>			<style type="text/css" id="wp-custom-css">
/*
You can add your own CSS here.
Click the help icon above to learn more.
*/
@media only screen and (max-width: 767px) {
.footer-categories {
display: block;
height: auto;
margin-bottom: 5px;
}
}			</style>
</head>
<body class="post-template-default single single-post postid-10233 single-format-standard custom-background chrome">
<div id="wrapper">
<div id="primary-nav">
<ul id="primary-navigation" class="nav"><li id="menu-item-144" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-144"><a href="#">Subscribe</a>
<ul class="sub-menu">
<li id="menu-item-149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149"><a href="https://diniservices.dticloud.com/cgi-bin/cmo_cmo.sh/custservice/web/addrfind.html">Print Newspaper</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="http://okeechobeenews.fl.newsmemory.com/">E-Newspaper</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="https://okeechobeenews.net/enewsletter/">Email Newsletter</a></li>
</ul>
</li>
<li id="menu-item-145" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-145"><a href="#">Reader Services</a>
<ul class="sub-menu">
<li id="menu-item-151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151"><a href="https://okeechobeenews.net/find/">Find the Okeechobee News</a></li>
<li id="menu-item-152" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152"><a href="https://newszap.com/#subscribe">Subscription Center</a></li>
<li id="menu-item-150" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-150"><a href="https://okeechobeenews.net/contact/">Contact Us</a></li>
<li id="menu-item-153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153"><a href="http://okeechobeenews.fl.newsmemory.com/marketplace.php">Print  Edition Ads</a></li>
<li id="menu-item-724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724"><a href="http://www.newslibrary.com/sites/onoo/">Online Print Archive</a></li>
</ul>
</li>
<li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18"><a href="https://floridaclassifieds.newszap.com/marketplace/">BizSearch</a></li>
<li id="menu-item-148" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-148"><a href="https://floridaclassifieds.newszap.com/">Classifieds</a></li>
<li id="menu-item-192" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-192"><a href="https://www.legacy.com/obituaries/newszapfl/">Obituaries</a></li>
<li id="menu-item-146" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-146"><a href="http://lakeokeechobeerealestate.fl.newsmemory.com/">Real Estate</a></li>
<li id="menu-item-147" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-147"><a href="https://floridaclassifieds.newszap.com/classifieds/other/">Legal Notices</a></li>
</ul>		<form method="get" id="searchform" action="https://okeechobeenews.net">
<fieldset>
<input type="text" name="s" id="s" placeholder="Search" />
</fieldset>
</form>
</div><!-- #primary-nav -->
<div id="header">
<a href="https://okeechobeenews.net"><img src="https://okeechobeenews.net/wp-content/uploads/2015/07/OkeeNewsLogo.jpg" alt="Okeechobee News" id="logo"/></a>
<div class='header-ad'><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<!-- fl-leaderboard-01 -->
<div id='div-gpt-ad-1372687360134-0' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-0'); });
</script>
</div></div>
</div>		<a class="button-menu" id="toggle" href="#"></a>			
<div class="clear"></div> 
</div><!-- #header-->
<div class="spacer_15"></div>
<div id="secondary-nav">
<ul id="secondary-navigation" class="nav"><li id="menu-item-2131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2131"><a href="#">News</a>
<ul class="sub-menu">
<li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://okeechobeenews.net/section/business/">Business</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44"><a href="https://okeechobeenews.net/section/government/">Government</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="https://okeechobeenews.net/section/health/">Health</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="https://okeechobeenews.net/section/lake-okeechobee/">Lake Okeechobee</a></li>
</ul>
</li>
<li id="menu-item-726" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-726"><a href="https://okeechobeenews.net/section/community-news/">Community</a></li>
<li id="menu-item-32" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32"><a href="https://okeechobeenews.net/section/crime/">Crime</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://okeechobeenews.net/section/schools/">Schools</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://okeechobeenews.net/section/sports/">Sports</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43"><a href="https://okeechobeenews.net/section/entertainment/">Entertainment</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://okeechobeenews.net/section/opinion/">Opinion</a></li>
<li id="menu-item-2130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2130"><a href="https://okeechobeenews.net/churchdirectory/">Churches</a></li>
<li id="menu-item-8532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-8532"><a href="#">Special Sections</a>
<ul class="sub-menu">
<li id="menu-item-8533" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8533"><a href="http://sections.iniusa.org/index.php?sortby=paper&#038;paper=Okeechobee+News">Special Sections</a></li>
<li id="menu-item-8534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8534"><a href="http://specialsections.newszap.com/">Archived Sections</a></li>
</ul>
</li>
</ul>	</div><!-- #secondary-nav -->
<div id="main">
<div id="content">
<div id="breadcrumbs">
<a href="https://okeechobeenews.net">Home</a> 
<a href="https://okeechobeenews.net/section/community-news/">Community News</a> <span class="entry-title">Great American Gun Show this weekend in LaBelle</span>				</div><!--end #breadcrumbs-->
<div id="post-10233" class="post-10233 post type-post status-publish format-standard has-post-thumbnail hentry category-community-news tag-business byline-special-to-the-okeechobee-news">
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_sharing_toolbox"></div>
<h1 class="entry-title">Great American Gun Show this weekend in LaBelle</h1>  
<div class="entry-meta">
<span class="entry-date">Jan 31st, 2018</span> &middot; by <a href="https://okeechobeenews.net/byline/special-to-the-okeechobee-news/" rel="tag">Special to the Okeechobee News</a> &middot;<span class="entry-comment"> Comments: <fb:comments-count href="https://okeechobeenews.net/community-news/great-american-gun-show-weekend-labelle/"></fb:comments-count></span>
</div><!-- .entry-meta -->
<div class="entry-content">
<p>LABELLE &#8212; The Great American Gun Show will be at the LaBelle Civic Center, 481 Hickpochee Ave., LaBelle (right behind city hall) Feb. 3 and 4. Saturday hours will be 9 a.m. to 5 p.m. Sunday hours will be 10 a.m. to 4 p.m.</p>
<p>Children age 12 and under will be admitted free with adult admission.</p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<div align="center">
<!-- fl-mediumrectangle-01 -->
<div id='div-gpt-ad-1372687360134-1' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-1'); });
</script>
</div>
</div></div>
<p>Concealed Carry Weapon classes will be available at 10 a.m. and 2 p.m. For information, call 561-214-5115.</p>
<p>Vendors may call 865-453-0074.</p>
<ul><p><em></em></p></ul>
<div class="entry-tags"><span>Tags:</span><a href="https://okeechobeenews.net/tag/business/" rel="tag">business</a></div>		  		<div class="clear"></div>
</div><!--end .entry-->
<?php echo category_description(); ?>	
</div><!-- #post-10233 -->
<div id='jp-relatedposts' class='jp-relatedposts' >
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>			
<div id="jp-relatedposts" class="jp-relatedposts" style="display: block;">
<h3 class="jp-relatedposts-headline">
<em>Newsletter</em>
</h3>
</div>
<!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//okeechobeenews.us8.list-manage.com/subscribe/post?u=c0b15575bb95f493b0c78850b&amp;id=23edd09a78" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to the Okeechobee News email newsletter</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_c0b15575bb95f493b0c78850b_23edd09a78" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<!--End mc_embed_signup-->
<div id="jp-relatedposts" class="jp-relatedposts" style="display: block;">
<h3 class="jp-relatedposts-headline">
<em>Comments</em>
</h3>
</div>
<p style="font-size:14px">
You are encouraged to leave relevant comments but engaging in personal attacks, threats, online bullying or commercial spam will not be allowed. All comments should remain within the bounds of fair play and civility. (You can disagree with others courteously, without being disagreeable.) Feel free to express yourself but keep an open mind toward finding value in what others say. To report abuse or spam, click the X in the upper right corner of the comment box.</p>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><div class="fb-comments" data-href="" data-numposts="3" data-width="375" data-colorscheme="light"></div>	
</div><!--end #content-->
<div id="sidebar">
<div id="ai_widget-2" class="widget ai_widget"><div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<!-- ROS top rectangle -->
<!-- fl-mediumrectangle-02 -->
<center>
advertisement
</center>
<div id='div-gpt-ad-1372687360134-2' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-2'); });
</script>
</div></div>
</div><div id="text-2" class="widget widget_text"><h3 class="widget-title">Print Edition</h3>			<div class="textwidget"><div class="inifrontpagewdg-wrapper">
<div class="spacer_10"></div>
<a href="http://okeechobeenews.fl.newsmemory.com/"><img src="https://okeechobeenews-fl.newsmemory.com/newsmemvol2/florida/okeechobeenews//prima/prima.jpg" alt="Okeechobee News front page"/></a>
<div class="spacer_10"></div>
The Okeechobee News is published every Wednesday, Friday, and Sunday. You can <a href="https://okeechobeenews.net/find/" title="Find the Newspaper">find it in retail outlets</a> throughout the Okeechobee area, or <a href="https://diniservices.dticloud.com/cgi-bin/cmo_cmo.sh/custservice/web/addrfind.html" title="subscribe">subscribe</a> to our print newspaper or our e-newspaper, a digital replica of the print edition.
</div></div>
</div>		
<div class="tj_widget_social">
<div class="social-icons">
<ul>
<li class="icon-rss"><a href="/feed/">Subscribe to<br />RSS</a></li>
<li class="icon-twitter"><a href="http://twitter.com/OkeechobeeNews">Follow on<br />Twitter</a></li>
<li class="icon-facebook"><a href="http://www.facebook.com/okeechobeenews">Join us on<br />Facebook</a></li>				
<li class="icon-enews"><a href="/enewsletter/">Sign-up for<br />Newsletter</a></li>
</ul>
<div class="clear"></div>
</div>
</div><!-- .tj_widget_social -->
<div id="custom_html-2" class="widget_text widget widget_custom_html"><h3 class="widget-title">Okeechobee Weather</h3><div class="textwidget custom-html-widget"><a href="/weather/"><img src="https://okeechobeenews.net/wp-content/uploads/2017/08/todaysweatherfinal.png"></a></div></div><div id="ai_widget-3" class="widget ai_widget"><div class='code-block code-block-5' style='margin: 8px 0; clear: both;'>
<!-- ROS bottom rectangle -->
<!-- fl-mediumrectangle-03 -->
<center>
advertisement
</center>
<div id='div-gpt-ad-1372687360134-3' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-3'); });
</script>
</div></div>
</div></div><!-- #sidebar -->
	</div><!-- #main -->
<div class="clear"></div>
<div class="footer-categories">
<ul>
<li><div class="menu-footer-container"><ul id="menu-footer" class="sf-menu"><li id="menu-item-6652" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6652"><a href="https://okeechobeenews.net/about/">About Us</a></li>
<li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://okeechobeenews.net/contact/">Contact Us</a></li>
<li id="menu-item-3283" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3283"><a href="https://newszap.com/pyn/fl/">Publish Your News</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-155"><a href="http://sections.iniusa.org/index.php?sortby=paper&#038;paper=Okeechobee+News">Special Sections</a></li>
</ul></div></a></li>
</ul>
<div class="clear"></div>
</div><!-- .footer-categories -->
<div class="copyright">
<p>&copy; 2018 <a href="/about/">Independent Newsmedia Inc. USA</a>. All rights reserved.</p>
<p><a href="http://www.theme-junkie.com">WordPress Theme</a> designed by <a href="http://www.theme-junkie.com">Theme Junkie</a></p>
</div><!-- .copyright -->
<div class="clear"></div>
</div><!-- #wrapper -->
<a id="back-to-top" href="#"></a>
<div style="display:none">
</div>
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-50786cb629e532c2" async="async"></script><script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201805'></script>
<script type='text/javascript' src='https://okeechobeenews.net/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://okeechobeenews.net/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://okeechobeenews.net/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://okeechobeenews.net/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://okeechobeenews.net/wp-content/plugins/theme-junkie-shortcodes/assets/js/junkie-shortcodes.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Janaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://okeechobeenews.net/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.2'></script>
<script type='text/javascript' src='https://okeechobeenews.net/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=4.9.2'></script>
<script type='text/javascript' src='https://okeechobeenews.net/wp-includes/js/comment-reply.min.js?ver=4.9.2'></script>
<script type='text/javascript' src='https://okeechobeenews.net/wp-includes/js/wp-embed.min.js?ver=4.9.2'></script>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=103764836632626&version=v2.3";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.538232088089 seconds, on 31-01-18 13:30:52 --><!-- via php -->