<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US"
xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<title>Land Development Regulations to allow medical marijuana dispensaries - Okeechobee News | Okeechobee News</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<!-- <link rel="stylesheet" type="text/css" media="all" href="http://okeechobeenews.net/wp-content/themes/newswire/style.css" /> -->
<link rel="alternate" type="application/rss+xml" title="Okeechobee News RSS Feed" href="http://okeechobeenews.net/feed/" />
<link rel="alternate" type="application/atom+xml" title="Okeechobee News Atom Feed" href="http://okeechobeenews.net/feed/atom/" />
<link rel="pingback" href="http://okeechobeenews.net/xmlrpc.php" />
<!-- <link rel="stylesheet" type="text/css" href="http://okeechobeenews.net/wp-content/themes/newswire/colors/default.css" /> -->
<!-- <link rel="stylesheet" type="text/css" href="http://okeechobeenews.net/wp-content/themes/newswire/css/media-queries.css" /> -->
<!-- <link rel="stylesheet" type="text/css" href="http://okeechobeenews.net/wp-content/themes/newswire/custom.css" /> -->
<link rel="stylesheet" type="text/css" href="//okeechobeenews.net/wp-content/cache/wpfc-minified/f7703e0ee9858941cffeff8081983eba/1505331176index.css" media="all"/>
<!--[if lt IE 9]>
<script src="http://css3-mediaqueries-js.googlecode.com/svn/trunk/css3-mediaqueries.js"></script>
<![endif]-->
<!-- MapPress Easy Google Maps Version:2.47.1 (http://www.wphostreviews.com/mappress) -->
<script type='text/javascript'>mapp = window.mapp || {}; mapp.data = [];</script>
<!-- This site is optimized with the Yoast SEO plugin v5.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://okeechobeenews.net/government/land-development-regulations-allow-medical-marijuana-dispensaries/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Land Development Regulations to allow medical marijuana dispensaries - Okeechobee News" />
<meta property="og:description" content="OKEECHOBEE &#8212; The Okeechobee County Commission voted 4-1 Thursday to amend the Land Development Regulations (LDRs) to allow medical marijuana dispensaries in the county. Commissioner Kelly Owens cast the lone dissenting vote. The public hearing was scheduled for 7 p.m. in order to make it easier for members of the public to participate. Dr. Ramesh &hellip;" />
<meta property="og:url" content="http://okeechobeenews.net/government/land-development-regulations-allow-medical-marijuana-dispensaries/" />
<meta property="og:site_name" content="Okeechobee News" />
<meta property="article:publisher" content="http://www.facebook.com/okeechobeenews" />
<meta property="article:tag" content="featured" />
<meta property="article:tag" content="medical marijuana" />
<meta property="article:section" content="Government" />
<meta property="article:published_time" content="2017-10-29T06:00:58-04:00" />
<meta property="article:modified_time" content="2017-10-27T13:34:20-04:00" />
<meta property="og:updated_time" content="2017-10-27T13:34:20-04:00" />
<meta property="fb:app_id" content="103764836632626" />
<meta property="og:image" content="http://okeechobeenews.net/wp-content/uploads/2017/02/Marijuana.jpg" />
<meta property="og:image:width" content="512" />
<meta property="og:image:height" content="507" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="OKEECHOBEE &#8212; The Okeechobee County Commission voted 4-1 Thursday to amend the Land Development Regulations (LDRs) to allow medical marijuana dispensaries in the county. Commissioner Kelly Owens cast the lone dissenting vote. The public hearing was scheduled for 7 p.m. in order to make it easier for members of the public to participate. Dr. Ramesh [&hellip;]" />
<meta name="twitter:title" content="Land Development Regulations to allow medical marijuana dispensaries - Okeechobee News" />
<meta name="twitter:site" content="@OkeechobeeNews" />
<meta name="twitter:image" content="http://okeechobeenews.net/wp-content/uploads/2017/02/Marijuana.jpg" />
<meta name="twitter:creator" content="@OkeechobeeNews" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/okeechobeenews.net\/","name":"Okeechobee News","potentialAction":{"@type":"SearchAction","target":"http:\/\/okeechobeenews.net\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/okeechobeenews.net\/government\/land-development-regulations-allow-medical-marijuana-dispensaries\/","sameAs":["http:\/\/www.facebook.com\/okeechobeenews","https:\/\/twitter.com\/OkeechobeeNews"],"@id":"#organization","name":"Okeechobee News","logo":"http:\/\/okeechobeenews.net\/wp-content\/uploads\/2015\/09\/arizona-favicon.jpg"}</script>
<!-- / Yoast SEO plugin. -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Okeechobee News &raquo; Feed" href="http://okeechobeenews.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Okeechobee News &raquo; Comments Feed" href="http://okeechobeenews.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Okeechobee News &raquo; Land Development Regulations to allow medical marijuana dispensaries Comments Feed" href="http://okeechobeenews.net/government/land-development-regulations-allow-medical-marijuana-dispensaries/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/okeechobeenews.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<meta content="/home/okeechobeenews/public_html/wp-content/themes/newswire/style.css v." name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<!-- <link rel='stylesheet' id='shortcodes-css'  href='http://okeechobeenews.net/wp-content/themes/newswire/functions/shortcodes/shortcodes.css?ver=4.8.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='gglcptch-css'  href='http://okeechobeenews.net/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.32' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mappress-css'  href='http://okeechobeenews.net/wp-content/plugins/mappress-google-maps-for-wordpress/css/mappress.css?ver=2.47.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='junkie-shortcodes-css'  href='http://okeechobeenews.net/wp-content/plugins/theme-junkie-shortcodes/assets/css/junkie-shortcodes.css?ver=4.8.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='tablepress-default-css'  href='http://okeechobeenews.net/wp-content/plugins/tablepress/css/default.min.css?ver=1.8.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='__EPYT__style-css'  href='http://okeechobeenews.net/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=4.8.2' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//okeechobeenews.net/wp-content/cache/wpfc-minified/52168ff0ca2dbbaaa2d9b6ed630554c4/1505331176index.css" media="all"/>
<style id='__EPYT__style-inline-css' type='text/css'>
.epyt-gallery-thumb {
width: 33.333%;
}
</style>
<!-- <link rel='stylesheet' id='jetpack_css-css'  href='http://okeechobeenews.net/wp-content/plugins/jetpack/css/jetpack.css?ver=5.4' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//okeechobeenews.net/wp-content/cache/wpfc-minified/78dc299d75fd51497d3e4d0aa9584521/1505331176index.css" media="all"/>
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js?ver=1.10.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"http:\/\/okeechobeenews.net\/wp-admin\/admin-ajax.php","security":"b909a23671","gallery_scrolloffset":"20","eppathtoscripts":"http:\/\/okeechobeenews.net\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"11.8.3","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","stopMobileBuffer":"1"};
/* ]]> */
</script>
<script src='//okeechobeenews.net/wp-content/cache/wpfc-minified/3960ceea8978c941acad5246dec8ebca/1505875762index.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='http://okeechobeenews.net/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=4.8.2'></script> -->
<!-- <script type='text/javascript' src='http://okeechobeenews.net/wp-content/themes/newswire/functions/shortcodes/shortcodes.js?ver=1.0.0'></script> -->
<!-- <script type='text/javascript' src='http://okeechobeenews.net/wp-content/themes/newswire/includes/js/jquery-ui-1.8.5.custom.min.js?ver=1.8.5'></script> -->
<!-- <script type='text/javascript' src='http://okeechobeenews.net/wp-content/themes/newswire/includes/js/superfish.js?ver=1.4.2'></script> -->
<!-- <script type='text/javascript' src='http://okeechobeenews.net/wp-content/themes/newswire/includes/js/custom.js?ver=1.4.2'></script> -->
<!-- <script type='text/javascript' src='http://okeechobeenews.net/wp-content/themes/newswire/includes/js/scrolltop.js?ver=1.0'></script> -->
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=1.0'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='http://okeechobeenews.net/wp-json/' />
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='http://wp.me/p7Bxc0-2m1' />
<link rel="alternate" type="application/json+oembed" href="http://okeechobeenews.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fokeechobeenews.net%2Fgovernment%2Fland-development-regulations-allow-medical-marijuana-dispensaries%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://okeechobeenews.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fokeechobeenews.net%2Fgovernment%2Fland-development-regulations-allow-medical-marijuana-dispensaries%2F&#038;format=xml" />
<meta property="fb:app_id" content="103764836632626"/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel="shortcut icon" href="http://okeechobeenews.net/wp-content/uploads/2015/09/arizona-favicon.jpg" /><!-- Custom Styling -->
<style type="text/css">
.entry-content p {
font-size: 16px;
line-height: 25px;
}
.entry-content ul {
font-size: 16px;
line-height: 25px;
}
.entry-content ul li {
padding: 2px 20px 15px 15px;
}
.entry-tags::before {
border-top: 1px solid #ddd;
content: "";
display: block;
margin-bottom: 1em;
min-width: 30px;
width: 100%;
}
body {
font: 12px/19px Georgia, Arial, "Lucida Grande", sans-serif;
}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="amphtml" href="http://okeechobeenews.net/government/land-development-regulations-allow-medical-marijuana-dispensaries/amp/" /><!-- custom CSS -->
<link rel="stylesheet" type="text/css" href="http://delawarestatenews.net/inicustom.css"/>
<!-- Doubleclick -->
<script type='text/javascript'>
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/83779297/fl-leaderboard-01', [728, 90], 'div-gpt-ad-1372687360134-0').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mediumrectangle-01', [300, 250], 'div-gpt-ad-1372687360134-1').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mediumrectangle-02', [300, 250], 'div-gpt-ad-1372687360134-2').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mediumrectangle-03', [300, 250], 'div-gpt-ad-1372687360134-3').addService(googletag.pubads());
googletag.defineOutOfPageSlot('/83779297/fl-mobile-adhesion-01', 'div-gpt-ad-1454707238781-4').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('community', ['Okeechobee']);
googletag.pubads().enableSyncRendering();
googletag.enableServices();
});
</script>
<!-- /83779297/fl-mobile-adhesion-01 -->
<div id='div-gpt-ad-1454707238781-4'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1454707238781-4'); });
</script>
</div>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-64247352-1', 'auto');
ga('send', 'pageview');
</script>			<style type="text/css" id="wp-custom-css">
/*
You can add your own CSS here.
Click the help icon above to learn more.
*/
@media only screen and (max-width: 767px) {
.footer-categories {
display: block;
height: auto;
margin-bottom: 5px;
}
}			</style>
</head>
<body class="post-template-default single single-post postid-9053 single-format-standard custom-background ie">
<div id="wrapper">
<div id="primary-nav">
<ul id="primary-navigation" class="nav"><li id="menu-item-144" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-144"><a href="#">Subscribe</a>
<ul  class="sub-menu">
<li id="menu-item-149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149"><a href="https://diniservices.dticloud.com/cgi-bin/cmo_cmo.sh/custservice/web/addrfind.html">Print Newspaper</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="http://okeechobeenews.fl.newsmemory.com/">E-Newspaper</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="http://okeechobeenews.net/enewsletter/">Email Newsletter</a></li>
</ul>
</li>
<li id="menu-item-145" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-145"><a href="#">Reader Services</a>
<ul  class="sub-menu">
<li id="menu-item-151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151"><a href="http://okeechobeenews.net/find/">Find the Okeechobee News</a></li>
<li id="menu-item-152" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152"><a href="https://newszap.com/#subscribe">Subscription Center</a></li>
<li id="menu-item-150" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-150"><a href="http://okeechobeenews.net/contact/">Contact Us</a></li>
<li id="menu-item-6720" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6720"><a href="https://newszap.com/pyn/fl/">Publish Your News</a></li>
<li id="menu-item-153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153"><a href="http://okeechobeenews.fl.newsmemory.com/marketplace.php">Print  Edition Ads</a></li>
<li id="menu-item-724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724"><a href="http://www.newslibrary.com/sites/onoo/">Online Print Archive</a></li>
</ul>
</li>
<li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18"><a href="https://floridaclassifieds.newszap.com/marketplace/">BizSearch</a></li>
<li id="menu-item-148" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-148"><a href="https://floridaclassifieds.newszap.com/">Classifieds</a></li>
<li id="menu-item-192" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-192"><a href="https://www.legacy.com/obituaries/newszapfl/">Obituaries</a></li>
<li id="menu-item-146" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-146"><a href="http://lakeokeechobeerealestate.fl.newsmemory.com/">Real Estate</a></li>
<li id="menu-item-147" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-147"><a href="https://floridaclassifieds.newszap.com/classifieds/other/">Legal Notices</a></li>
</ul>		<form method="get" id="searchform" action="http://okeechobeenews.net">
<fieldset>
<input type="text" name="s" id="s" placeholder="Search" />
</fieldset>
</form>
</div><!-- #primary-nav -->
<div id="header">
<a href="http://okeechobeenews.net"><img src="http://okeechobeenews.net/wp-content/uploads/2015/07/OkeeNewsLogo.jpg" alt="Okeechobee News" id="logo"/></a>
<div class='header-ad'><!-- fl-leaderboard-01 -->
<div id='div-gpt-ad-1372687360134-0' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-0'); });
</script>
</div></div>		<a class="button-menu" id="toggle" href="#"></a>			
<div class="clear"></div> 
</div><!-- #header-->
<div id="secondary-nav">
<ul id="secondary-navigation" class="nav"><li id="menu-item-726" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-726"><a href="http://okeechobeenews.net/section/community-news/">Community</a></li>
<li id="menu-item-2130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2130"><a href="http://okeechobeenews.net/churchdirectory/">Churches</a></li>
<li id="menu-item-32" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32"><a href="http://okeechobeenews.net/section/crime/">Crime</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-43"><a href="http://okeechobeenews.net/section/entertainment/">Entertainment</a>
<ul  class="sub-menu">
<li id="menu-item-5120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5120"><a href="http://okeechobeenews.net/section/musicfest/">Music Festival</a></li>
</ul>
</li>
<li id="menu-item-2131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2131"><a href="#">News</a>
<ul  class="sub-menu">
<li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="http://okeechobeenews.net/section/business/">Business</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-44"><a href="http://okeechobeenews.net/section/government/">Government</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="http://okeechobeenews.net/section/health/">Health</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="http://okeechobeenews.net/section/lake-okeechobee/">Lake Okeechobee</a></li>
</ul>
</li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="http://okeechobeenews.net/section/opinion/">Opinion</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="http://okeechobeenews.net/section/schools/">Schools</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="http://okeechobeenews.net/section/sports/">Sports</a></li>
<li id="menu-item-8532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-8532"><a href="#">Special Sections</a>
<ul  class="sub-menu">
<li id="menu-item-8533" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8533"><a href="http://sections.iniusa.org/index.php?sortby=paper&#038;paper=Okeechobee+News">Special Sections</a></li>
<li id="menu-item-8534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8534"><a href="http://specialsections.newszap.com/">Archived Sections</a></li>
</ul>
</li>
</ul>	</div><!-- #secondary-nav -->
<div id="main">
<div id="content">
<div id="breadcrumbs">
<a href="http://okeechobeenews.net">Home</a> 
<a href="http://okeechobeenews.net/section/government/">Government</a> <span class="entry-title">Land Development Regulations to allow medical marijuana dispensaries</span>				</div><!--end #breadcrumbs-->
<div id="post-9053" class="post-9053 post type-post status-publish format-standard has-post-thumbnail hentry category-government tag-featured tag-medical-marijuana byline-katrina-elsken">
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_sharing_toolbox"></div>
<h1 class="entry-title">Land Development Regulations to allow medical marijuana dispensaries</h1>  
<div class="entry-meta">
<span class="entry-date">Oct 29th, 2017</span> &middot; by <a href="http://okeechobeenews.net/byline/katrina-elsken/" rel="tag">Katrina Elsken</a> &middot;<span class="entry-comment"> Comments: <fb:comments-count href="http://okeechobeenews.net/government/land-development-regulations-allow-medical-marijuana-dispensaries/"></fb:comments-count></span>
</div><!-- .entry-meta -->
<div class="entry-content">
<p>OKEECHOBEE &#8212; The Okeechobee County Commission voted 4-1 Thursday to amend the Land Development Regulations (LDRs) to allow medical marijuana dispensaries in the county. Commissioner Kelly Owens cast the lone dissenting vote.</p>
<p>The public hearing was scheduled for 7 p.m. in order to make it easier for members of the public to participate. Dr. Ramesh Kumar, who has a cancer practice in Okeechobee, was the only member of the public to address the commission.</p>
<p>“The system that creates marijuana in plants exists in human beings — the same identical system,” he said.</p>
<p>“When you take a run and you feel that high, the endorphin system kicks in. In diseased states and aging, somehow we lose that,” he said.</p>
<p>“The reason I got involved in the medical cannabis world is a personal story, My mother-in-law was diagnosed with breast cancer, which was widespread. We tried chemo, nothing worked.</p>
<p>“She was on her death bed when my wife flew out to California to say her last good-bye.</p>
<p>This was five years ago,” he continued. He said his wife called him and asked if medical marijuana might help her mother. He said he did research to find out if medical marijuana could make a difference in his mother-in-law’s quality of life, and they decided to try it.</p>
<p>“She had great quality of life. From being on her death bed, within about a week, to being able to go out into the garden and dig up her flower beds and being able to walk and function,” he continued. Although she died seven months later, “the point is this has to do with quality of life,” he said.</p>
<p>He said he became a proponent of the use of medical marijuana for terminally-ill cancer patients.</p>
<p>“I am getting calls from lots of patients about getting medical cannabis,” he said. “I am so afraid that medical cannabis can go the way of the pill mills.”</p>
<p>“I consider medical cannabis as a pharmaceutical medicine,” he explained.</p>
<p>“We are getting some angry calls from patients who think they have this condition just on hearsay — ‘oh I think I have PTSD so I want marijuana’ — which is not right.</p>
<p>“Some of my brothers in the medical field have made it a commodity,” he continued.</p>
<p>He said he wants medical marijuana for his patients, but also wants to be sure that those who are prescribed medical marijuana are monitored by doctors.</p>
<p>“How can we on one hand make it easily available for patients who need it, and how do we monitor our brothers and sisters in the medical field?” he asked.</p>
<p>“When I do prescribe medical cannabis, I make a medical decision on the amount, the route of administration, the quantity and the duration,” he said.</p>
<p>Commission Chairman Terry Burroughs said the number of dispensaries allowed in each region is determined by the state.</p>
<p>“That’s out of our hands,” he said. The county can only determine where the dispensaries can be allowed within the county.</p>
<p>“The conversation we are having tonight is about changing the land use regulations for a business that is still going through the process of state regulatory mandates,” said Commissioner Kelly Owens. “I want to be clear. I am not asking for a ban. We’ve gone past that and I understand that.</p>
<p>“I am simply asking as a commission that we wait until we can make an informed decision based on determined, adopted regulations. To do anything less is not responsible government in my opinion. If any other business was before us, and it was still going through state regulatory mandates, I would have the same opinion.”</p>
<p>Chairman Burroughs asked Commissioner Owens to clarify her statement.</p>
<p>“The regulations are still being determined by the Department of Health for the state,” said Commissioner Owens.</p>
<p>“The Department of Health has them, but as of today, will not release them because of a lawsuit,” said Chairman Burroughs.</p>
<p>“I hear a lot of people around the county, you see it on social media, they say nobody knows what’s going on,” said Commissioner Brad Goodbread.</p>
<p>“Today I put on social media, every site I could find, that this meeting is here at 7 p.m., what it was for, and basically the only person who came to speak, Dr. Kumar, was invited by a commissioner to give information on the subject.</p>
<p>“I did everything I could to make sure that everybody knew, and nobody showed,” he said.</p>
<p>“We’ve already said we are going to allow it. The only question is where,” said Commissioner Culpepper. He added that the state regulations have determined rules such as how close a dispensary can be to a school.</p>
<p>“There is a lawsuit right now. We don’t know how that will end up,” he said.</p>
<p>The lawsuit is relative to co-op of farmers, said Chairman Burroughs.</p>
<p>“We have over 60-something percent of people in this community who have said they are in favor of this,” he said. “People voted that they wanted this.”</p>
<p>Commissioner David Hazellief said, “when we have 60 something percent of the people vote for this, I think it is our job to listen to them.”</p>
<p>“I agree. When the majority of the community says this is what we want, it is incumbent on us to determine how we accommodate that wish,” said Commissioner Owens.</p>
<p>On Sept. 22, a lawsuit was filed by Columbus Smith, a farmer from Panama City, who alleges the state law is unconstitutional because it is so narrowly written that only a handful of black farmers could qualify for a license to grow medical marijuana.</p>
<p>In the 2016 election, 8,886 Okeechobee County voters voted ‘yes’ and 4,504 voted ‘no’ on the medical marijuana amendment to the state constitution. Thus, 66.36 percent of the votes cast in the county were in favor of medical marijuana.</p>
<ul><p><em>Editor Katrina Elsken can be reached at <a href="mailto:kelsken@newszap.com">kelsken@newszap.com</a></em></p></ul>
<div class="entry-tags"><span>Tags:</span><a href="http://okeechobeenews.net/tag/featured/" rel="tag">featured</a> &middot; <a href="http://okeechobeenews.net/tag/medical-marijuana/" rel="tag">medical marijuana</a></div>		  		<div class="clear"></div>
</div><!--end .entry-->
<?php echo category_description(); ?>	
<div class="entry-related">
<h3 class="section-title">Related Posts</h3>
<ul class="related-loop">		
<li >
<a href="http://okeechobeenews.net/community-news/inspiring-okeechobee-local-veteran-goes-honor-flight/" rel="bookmark"><img width="120" height="80" src="http://okeechobeenews.net/wp-content/uploads/2017/10/Inspiring-pic2-120x80.jpg" class="entry-thumb wp-post-image" alt="" /></a>
<h2 class="entry-title"><a title="Inspiring Okeechobee Local veteran goes on honor flight" href="http://okeechobeenews.net/community-news/inspiring-okeechobee-local-veteran-goes-honor-flight/">Inspiring Okeechobee Local veteran goes on honor flight</a></h2>
<div class="entry-meta">
10/29/2017 &middot; <a href="http://okeechobeenews.net/community-news/inspiring-okeechobee-local-veteran-goes-honor-flight/#respond">0 Comment</a>	</div><!--end .entry-meta-->
</li>			
<li >
<a href="http://okeechobeenews.net/community-news/okeechobee-koa-hosts-oktoberfest-dachshund-racing/" rel="bookmark"><img width="120" height="80" src="http://okeechobeenews.net/wp-content/uploads/2017/10/D2X_0034-1-120x80.jpg" class="entry-thumb wp-post-image" alt="" /></a>
<h2 class="entry-title"><a title="Okeechobee KOA hosts Oktoberfest with dachshund racing" href="http://okeechobeenews.net/community-news/okeechobee-koa-hosts-oktoberfest-dachshund-racing/">Okeechobee KOA hosts Oktoberfest with dachshund racing</a></h2>
<div class="entry-meta">
10/28/2017 &middot; <a href="http://okeechobeenews.net/community-news/okeechobee-koa-hosts-oktoberfest-dachshund-racing/#respond">0 Comment</a>	</div><!--end .entry-meta-->
</li>			
<li class="last-entry">
<a href="http://okeechobeenews.net/crime/kramer-found-guilty-fatal-motorcycle-crash/" rel="bookmark"><img width="120" height="80" src="http://okeechobeenews.net/wp-content/uploads/2017/10/KRAMER-LISA-MARIE-web-120x80.jpg" class="entry-thumb wp-post-image" alt="" /></a>
<h2 class="entry-title"><a title="Kramer found guilty in fatal motorcycle crash" href="http://okeechobeenews.net/crime/kramer-found-guilty-fatal-motorcycle-crash/">Kramer found guilty in fatal motorcycle crash</a></h2>
<div class="entry-meta">
10/27/2017 &middot; <a href="http://okeechobeenews.net/crime/kramer-found-guilty-fatal-motorcycle-crash/#respond">0 Comment</a>	</div><!--end .entry-meta-->
</li>			
</ul>		
<div class="single-ad">
<!-- fl-mediumrectangle-01 -->
<div id='div-gpt-ad-1372687360134-1' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-1'); });
</script>
</div>				</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
</div><!-- #post-9053 -->
<!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//okeechobeenews.us8.list-manage.com/subscribe/post?u=c0b15575bb95f493b0c78850b&amp;id=23edd09a78" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to the Okeechobee News email newsletter</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_c0b15575bb95f493b0c78850b_23edd09a78" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<!--End mc_embed_signup-->
<div id="jp-relatedposts" class="jp-relatedposts" style="display: block;">
<h3 class="jp-relatedposts-headline">
<em>Comments</em>
</h3>
</div>
<div>
You are encouraged to leave relevant comments but engaging in personal attacks, threats, online bullying or commercial spam will not be allowed. All comments should remain within the bounds of fair play and civility. (You can disagree with others courteously, without being disagreeable.) Feel free to express yourself but keep an open mind toward finding value in what others say. To report abuse or spam, click the X in the upper right corner of the comment box.</div>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><div class="fb-comments" data-href="" data-numposts="3" data-width="375" data-colorscheme="light"></div>	
</div><!--end #content-->
<div id="sidebar">
<div class="widget-ads widget"><h3 class="ad-title">advertisement</h3>		
<!-- ROS top rectangle -->
<!-- fl-mediumrectangle-02 -->
<div id='div-gpt-ad-1372687360134-2' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-2'); });
</script>
</div>		
</div><div id="text-2" class="widget widget_text"><h3 class="widget-title">Print Edition</h3>			<div class="textwidget"><div class="inifrontpagewdg-wrapper">
<div class="spacer_10"></div>
<a href="http://okeechobeenews.fl.newsmemory.com/"><img src="https://okeechobeenews-fl.newsmemory.com/newsmemvol2/florida/okeechobeenews//prima/prima.jpg" alt="Okeechobee News front page"/></a>
<div class="spacer_10"></div>
The Okeechobee News is published every Wednesday, Friday, and Sunday. You can <a href="http://okeechobeenews.net/find/" title="Find the Newspaper">find it in retail outlets</a> throughout the Okeechobee area, or <a href="https://diniservices.dticloud.com/cgi-bin/cmo_cmo.sh/custservice/web/addrfind.html" title="subscribe">subscribe</a> to our print newspaper or our e-newspaper, a digital replica of the print edition.
</div></div>
</div>		
<div class="tj_widget_social">
<div class="social-icons">
<ul>
<li class="icon-rss"><a href="http://feeds.feedblitz.com/okeechobeenews">Subscribe to<br />RSS</a></li>
<li class="icon-twitter"><a href="http://twitter.com/OkeechobeeNews">Follow on<br />Twitter</a></li>
<li class="icon-facebook"><a href="http://www.facebook.com/okeechobeenews">Join us on<br />Facebook</a></li>				
<li class="icon-enews"><a href="http://okeechobeenews.net/enewsletter/">Sign-up for<br />Newsletter</a></li>
</ul>
<div class="clear"></div>
</div>
</div><!-- .tj_widget_social -->
<div id="custom_html-2" class="widget_text widget widget_custom_html"><h3 class="widget-title">Okeechobee Weather</h3><div class="textwidget custom-html-widget"><a href="/weather/"><img src="http://okeechobeenews.net/wp-content/uploads/2017/08/todaysweatherfinal.png"></a></div></div><div class="widget-ads widget"><h3 class="ad-title">advertisement</h3>		
<!-- ROS bottom rectangle -->
<!-- fl-mediumrectangle-03 -->
<div id='div-gpt-ad-1372687360134-3' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-3'); });
</script>
</div>		
</div></div><!-- #sidebar -->
	</div><!-- #main -->
<div class="clear"></div>
<div class="footer-categories">
<ul>
<li><div class="menu-footer-container"><ul id="menu-footer" class="sf-menu"><li id="menu-item-6652" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6652"><a href="http://okeechobeenews.net/about/">About Us</a></li>
<li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="http://okeechobeenews.net/contact/">Contact Us</a></li>
<li id="menu-item-3283" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3283"><a href="https://newszap.com/pyn/fl/">Publish Your News</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-155"><a href="http://sections.iniusa.org/index.php?sortby=paper&#038;paper=Okeechobee+News">Special Sections</a></li>
</ul></div></a></li>
</ul>
<div class="clear"></div>
</div><!-- .footer-categories -->
<div class="copyright">
<p>&copy; 2017 <a href="/about/">Independent Newsmedia Inc. USA</a>. All rights reserved.</p>
<p><a href="http://www.theme-junkie.com">WordPress Theme</a> designed by <a href="http://www.theme-junkie.com">Theme Junkie</a></p>
</div><!-- .copyright -->
<div class="clear"></div>
</div><!-- #wrapper -->
<a id="back-to-top" href="#"></a>
<div style="display:none">
</div>
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-50786cb629e532c2" async="async"></script><script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201743'></script>
<script type='text/javascript' src='http://okeechobeenews.net/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://okeechobeenews.net/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://okeechobeenews.net/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://okeechobeenews.net/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://okeechobeenews.net/wp-content/plugins/theme-junkie-shortcodes/assets/js/junkie-shortcodes.js'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Octaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://okeechobeenews.net/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://okeechobeenews.net/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://okeechobeenews.net/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://okeechobeenews.net/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=103764836632626&version=v2.3";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.523542165756 seconds, on 29-10-17 6:03:32 -->